能否成环

能否成环

Description

Given an array of strings A[ ], determine if the strings can be chained together to form a circle. A string X can be chained together with another string Y if the last character of X is same as first character of Y. If every string of the array can be chained, it will form a circle. For example, for the array arr[] = {"for", "geek", "rig", "kaf"} the answer will be Yes as the given strings can be chained as "for", "rig", "geek" and "kaf".

给定一个字符串数组A[],判断这些字符串是否可以链接在一起形成一个圆。如果X的最后一个字符与Y的第一个字符相同,则可以将一个字符串X与另一个字符串Y链接在一起。例如,对于数组arr[] = {" for ", "geek", "rig", "kaf"},答案将是Yes,因为给定的字符串可以被链接为"for", "rig", "geek"和"kaf"

Input

The first line of input contains an integer T denoting the number of test cases. Then T test cases follow.
The first line of each test case contains a positive integer N, denoting the size of the array.
The second line of each test case contains a N space seprated strings, denoting the elements of the array A[ ].
1 <= T
0 < N
0 < A[i]

输入的第一行包含一个整数T,表示测试用例的数量。然后是测试用例。
每个测试用例的第一行包含一个正整数N,表示数组的大小。
每个测试用例的第二行包含一个N个分隔的字符串,表示数组A[]的元素。

Output

If chain can be formed, then print 1, else print 0.

如果可以形成环,则打印1,否则打印0。

Sample Input

2
3
abc bcd cdf
4
ab bc cd da

Sample Output

0
1

Solution

图是否可以具有遍历所有顶点的循环:
1.对于同一顶点,出度=入度
2.强连接。即对每个顶点使用深度优先遍历,遍历完后图中所有顶点都应该被访问

public class Chain {

    public static void main(String[] args){
        Scanner in = new Scanner(System.in);
        int caseNum = in.nextInt();
        for(int i = 0; i < caseNum; i++){
            int len = in.nextInt();
            List<String> strList = new ArrayList<>();
            for(int j = 0; j < len; j++){
                strList.add(in.next());
            }
            if(isChain(strList)){
                System.out.println(1);
            }
            else{
                System.out.println(0);
            }
        }
    }

    public static boolean isChain(List<String> stringList){
        boolean[][] hasEdge = new boolean[26][26];
        boolean[] isVertax = new boolean[26];
        int[] in = new int[26];
        int[] out = new int[26];

        for(int i = 0; i < stringList.size(); i++){
            String str = stringList.get(i);
            int first = str.charAt(0) - 'a';
            int last = str.charAt(str.length() - 1) - 'a';
            isVertax[first] = true;
            isVertax[last] = true;
            out[first]++;
            in[last]++;
            hasEdge[first][last] = true;
        }

        for(int i = 0; i < 26; i++){
            if(in[i] != out[i]){
                return false;
            }
        }

        int start = stringList.get(0).charAt(0) - 'a';
        return isStronglyConnected(hasEdge, isVertax, start);
    }

    public static boolean isStronglyConnected(boolean[][] hasEdge, boolean[] isVertax, int start){
        boolean[] isVisited = new boolean[26];
        dfs(hasEdge, start, isVisited);
        for(int i = 0; i < 26; i++){
            if(isVertax[i] && !isVisited[i]){
                return false;
            }
        }
        return true;
    }

    public static void dfs(boolean[][] hasEdge, int start, boolean[] isVisited){
        isVisited[start] = true;
        for(int i = 0; i < 26; i++){
            if(hasEdge[start][i]){
                if(!isVisited[i]){
                    dfs(hasEdge, i, isVisited);
                }
            }
        }
    }
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 219,366评论 6 508
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 93,521评论 3 395
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 165,689评论 0 356
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,925评论 1 295
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,942评论 6 392
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,727评论 1 305
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,447评论 3 420
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 39,349评论 0 276
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,820评论 1 317
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,990评论 3 337
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 40,127评论 1 351
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,812评论 5 346
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,471评论 3 331
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 32,017评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 33,142评论 1 272
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 48,388评论 3 373
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 45,066评论 2 355

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,336评论 0 10
  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,511评论 0 23
  • pyspark.sql模块 模块上下文 Spark SQL和DataFrames的重要类: pyspark.sql...
    mpro阅读 9,457评论 0 13
  • mean to add the formatted="false" attribute?.[ 46% 47325/...
    ProZoom阅读 2,699评论 0 3
  • 愿你有好运气,如果没有,愿你在不幸中学会慈悲。 愿你被很多人爱,如果没有,愿你在寂寞中学会宽容。 愿你一生一世每天...
    期待彩虹阅读 300评论 0 5