题目:
Problem Description
Zeus 和 Prometheus 做了一个游戏,Prometheus 给 Zeus 一个集合,集合中包含了N个正整数,随后 Prometheus 将向 Zeus 发起M次询问,每次询问中包含一个正整数 S ,之后 Zeus 需要在集合当中找出一个正整数 K ,使得 K 与 S 的异或结果最大。Prometheus 为了让 Zeus 看到人类的伟大,随即同意 Zeus 可以向人类求助。你能证明人类的智慧么?
Input
输入包含若干组测试数据,每组测试数据包含若干行。
输入的第一行是一个整数T(T < 10),表示共有T组数据。
每组数据的第一行输入两个正整数N,M(<1=N,M<=100000),接下来一行,包含N个正整数,代表 Zeus 的获得的集合,之后M行,每行一个正整数S,代表 Prometheus 询问的正整数。所有正整数均不超过2^32。
Output
对于每组数据,首先需要输出单独一行”Case #?:”,其中问号处应填入当前的数据组数,组数从1开始计算。
对于每个询问,输出一个正整数K,使得K与S异或值最大。
Sample Input
2
3 2
3 4 5
1
5
4 1
4 6 5 6
3
Sample Output
Case #1:
4
3
Case #2:
4
很明显,直接暴力求该值与数组中的值的异或然后比较大小肯定过不了。
由于异或运算是位运算,因此这道题可以将这些数字转换为二进制数,二进制数只有0或1,而异或出来的值如果为1,则它越靠近高位,最终异或的结果越大。因此,我们可以用字典树维护。
异或是相同为0,不同为1,因此在对要查询的数进行处理时,该位为1则变为0,该位为0则变为1.
高位不足则补0.
这道题虽然是字典树,但是要处理的细节很多,这道题也不算简单。
参考代码:
#include <iostream>
#include <cstring>
#include <algorithm>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const int N = 100000+10;
typedef long long LL;
struct Trie {
LL f;
Trie *next[2];//0 and 1;
};
Trie *root;
int a[35];//保存数字转换为二进制之后的每一位数;
void change(LL num) {
int i = 0;
while (num) {
a[i++] = num % 2;
num = num / 2;
}
}
void createTrie(int a[]) {
Trie *p = root, *q;
int len = 34;//高位靠近树根;
while (len >= 0) {
int id = a[len];
if (p->next[id] == NULL) {
q = new Trie();
for (int i = 0;i < 2;++i) {
q->next[i] = NULL;
}
p->next[id] = q;
p = p->next[id];
}
else {
p = p->next[id];
}
if (id) p->f = (LL) (1) << len;//如果下标为1, 表明该权重有值;
--len;
}
}
LL findTrie(int a[]) {
Trie *p = root;
int len = 34;
LL ans = 0;
while (len >= 0) {
int id = a[len];
if (p->next[id] == NULL) {//所有的数字的二进制数都没有以id值为最高位;
id = id ^ 1;
}
p = p->next[id];
if (id) {
//cout << s.size() << " " << id << endl;
ans += p->f;
}
--len;
}
return ans;
}
int main() {
ios::sync_with_stdio(false);
cin.tie(NULL);
int t;
cin >> t;
for (int cnt = 1;cnt <= t;++cnt) {
root = new Trie();
root->next[0] = NULL;
root->next[1] = NULL;
int n, m;
cin >> n >> m;
LL number;
for (int i = 1;i <= n;++i) {
cin >> number;
memset(a, 0, sizeof(a));//初始化;
change(number);
createTrie(a);
}
int query;
cout << "Case #" << cnt << ":" << endl;
for (int i = 1;i <= m;++i) {
cin >> query;
memset(a, 0, sizeof(a));
change(query);
for (int i = 0;i < 35;++i) {
a[i] = a[i] ^ 1;//转换;//两数异或, 不相同为1, 这里转换后就变为相同为1;
}
LL ans = findTrie(a);
cout << ans << endl;
}
delete root;
}
return 0;
}