题目描述
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
考点
拓扑排序的判断
思路
1.解题思路
存储每个顶点的入度与边信息,判断当前顶点的入度是否为0,如果为0则将当前顶点指向的顶点的入度-1,循环继续;否则打印出当前的i
,循环结束。
2.vector的循环
for (int it : e[s]) p[it]--;
3.关于vector二维数组的初始化以及赋值
初始化:vector<vector<int>> e(n+1);
赋值:e[a].push_back(b);
代码
#include <iostream>
#include <vector>
using namespace std;
int main() {
int n, m, k, first = 1, flag;
cin >> n >> m;
vector<vector<int>> e(n + 1);
vector<int> in(n + 1, 0);
for (int i = 0; i < m; i++) {
int a, b;
cin >> a >> b;
e[a].push_back(b);
in[b]++;
}
cin >> k;
for (int i = 0; i < k; i++) {
flag = 1;
vector<int> p(in);
for (int j = 0; j < n; j++) {
int s;
cin >> s;
if (p[s] != 0) flag = 0;
for (int it : e[s]) p[it]--;
}
if (!flag) {
cout << (first == 1 ? "" : " ") << i;
first = 0;
}
}
return 0;
}