Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 89483 Accepted Submission(s): 36838
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
<pre style="overflow-wrap: break-word; white-space: pre-wrap; margin: 0px; font-size: 14px;">
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
14
#include <iostream>
using namespace std;
int max(int a, int b) {
return a > b ? a : b;
}
int dp[1005][1005] ;
void main() {
int t;
int n;
int v;
cin >> t;
int va[1000], vo[1000];
while (t--) {
cin >> n>>v;
for (int i = 1; i <= n; i++)
cin >> va[i];
for (int i = 1; i <= n; i++)
cin >> vo[i];
memset(dp, 0, sizeof(dp));
for (int i = 1; i <= n; i++) {
for (int j = 0; j <= v; j++)//要记得有容量为0的情况
{
if (vo[i] > j) { dp[i][j] = dp[i - 1][j]; }
else if(vo[i] <= j) { dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - vo[i]] + va[i]); }
}
}
cout << dp[n][v] << endl;
}
}