算法练习题1:第N个闰年是?

题目

Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
Output
For each test case, you should output the Nth leap year from year Y.
Sample Input
3
2005 25
1855 12
2004 10000
Sample Output
2108
1904
43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.


问题描述
Ignatius出生在闰年,所以他想知道什么时候可以举办他的生日派对。你能告诉他吗?
给定表示起始年份的正整数Y和正整数N,您的任务是告诉从Y年开始的第N个闰年。
注意:如果Y年是闰年,那么第一个闰年是Y年。
输入
输入包含几个测试用例。输入的第一行是单个整数T,它是测试用例的数量。 T测试案例如下。
每个测试用例包含两个正整数Y和N(1 <= N <= 10000)。
产量
对于每个测试用例,您应该从Y年输出第N个闰年。
样本输入
3
2005年25
1855年12月
2004年10000
样本输出
2108
1904
43236
暗示
只有当(Y%4 == 0 && Y%100!= 0)或Y%400 == 0时,我们才将Y年称为闰年。
作者
Ignatius.L

答案

import java.io.IOException;
import java.util.Scanner;

public class Main {

    public  static boolean isLeapYear (int year) {
        if ((year % 4 == 0 && year % 100 != 0 )|| year % 400 == 0)
            return true;
        return  false;
    }

    public static int closeLeapYear (int year) {
        if (isLeapYear(year)) return year;
        int resultYear = year;
        for (int i = 0; i < 8; ++i) {
            resultYear = year + i;
            if (isLeapYear(resultYear)) {
                break;
            }
        }
        return resultYear;
    }

    public static int resultYear(int year,int n) {
        int resultYear = closeLeapYear(year);
        for (int i = 0 ; i != n; ) {
            boolean isLeap = isLeapYear(resultYear + 4 );
            if (isLeap) {
                i++;
            }
            resultYear = resultYear + 4;
        }

        return resultYear - 4;
    }



    public static void main(String[] args) throws IOException {

        Scanner in = new Scanner(System.in);
        int times = 0;
        int[] results = new int[0];
        int index = 0;
        int total = 0;
        while(in.hasNext()) {
            String a = in.nextLine();
            if (!a.contains(" ")) {
                total = Integer.valueOf(a);
                times = total;
                if (times < 1) {
                    break;
                } else {
                    continue;
                }
            }
            if (results.length < 1) {
                results = new int[total];
            }

            if (times > 0) {
                String[] result = a.split(" ");
                String year = result[0];
                int yearInt = Integer.valueOf(year);
                String n = result[1];
                int nInt = Integer.valueOf(n);
                int resultYear = resultYear(yearInt,nInt);
                results[index++] = resultYear;

                times--;
            }

            if (times == 0){
                for (int i = 0; i < results.length; i++) {
                    System.out.println(results[i]);
                }
                break;
            }
        }

    }
}

测试用例

测试用例
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,496评论 6 501
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,407评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,632评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,180评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,198评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,165评论 1 299
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,052评论 3 418
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,910评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,324评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,542评论 2 332
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,711评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,424评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,017评论 3 326
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,668评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,823评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,722评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,611评论 2 353