PAT甲级1127-ZigZagging on a Tree(后序中序建树,层序遍历)

一.题目

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

二.题意

给出一个树的中序和后序遍历的结果,求它的Z字型层序遍历,也就是偶数层从右向左,奇数层从左到右遍历

三.代码部分

#include<bits/stdc++.h>
using namespace std;
vector<int> in,post,result[35];
int n,tree[35][2],root;
struct node{
    int index,depth;//树的值与深度
};
void dfs(int &index, int inLeft, int inRight, int postLeft, int postRight) {//使用&的原因是index的值需要改变
    if (inLeft > inRight) return;//dfs的循环跳出的条件
    index = postRight;//当前根节点的下标
    int i = 0;
    while (in[i] != post[postRight]) i++;//寻找后序的根在中序遍历的位置
    dfs(tree[index][0], inLeft, i - 1, postLeft, postLeft + (i - inLeft) - 1);//递归遍历左子树
    dfs(tree[index][1], i + 1, inRight, postLeft + (i - inLeft), postRight - 1);//递归遍历右子树
}
void bfs(){//层序遍历
    queue<node> q;
    q.push(node{root,0});//根节点push进queue
    while(!q.empty()){
        node temp=q.front();
        q.pop();
        result[temp.depth].push_back(post[temp.index]);//增加depth的信息
        if(tree[temp.index][0]!=0)//左子树
            q.push(node{tree[temp.index][0],temp.depth+1});
        if(tree[temp.index][1]!=0)//右子树
            q.push(node{tree[temp.index][1],temp.depth+1});
    }
}
int main() {
    cin >> n;
    in.resize(n + 1), post.resize(n + 1);//重新设置大小为n+1
    for (int i = 1; i <= n; i++) cin >> in[i];//输入中序序列
    for (int i = 1; i <= n; i++) cin >> post[i];//输入后序序列
    dfs(root, 1, n, 1, n);//dfs进行遍历
    bfs();//层序遍历,将信息添加到node中
    printf("%d", result[0][0]);//首先输出根节点
    for (int i = 1; i < 35; i++) {
        if (i % 2 == 1) {//奇数层
            for (int j = 0; j < result[i].size(); j++)
                printf(" %d", result[i][j]);//逐个输出
        } else {//偶数层
            for (int j = result[i].size() - 1; j >= 0; j--)
                printf(" %d", result[i][j]);//逐个输出
        }
    }
    return 0;
}

沉神的代码

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,390评论 5 459
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,821评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,632评论 0 319
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,170评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,033评论 4 355
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,098评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,511评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,204评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,479评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,572评论 2 309
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,341评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,213评论 3 312
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,576评论 3 298
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,893评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,171评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,486评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,676评论 2 335