pat贪心算法实例1033 To Fill or Not to Fill

1033 To Fill or Not to Fill (25分)
With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax(≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg(≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di(≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.


Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17


Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00


题目大意:距离为D的两地之间有n个加油站,每个加油站油价Pi不同,问是否能够到达以及能够到达算出最低的油价。规定一辆车的邮箱容量Cmax以及每升油能跑多少公里Da,默认刚开始车没油。

分析:
将各个加油站按与起始点的距离由小到大排列
1.如果最近的加油站不在起始点,则车无法启动,输入最大行驶距离为0
2.选择下一个加油站(优先级由高到低排序)
-加满油能到达并且价格比此站更低的,如果存在,在此车站是需要把油加到能够到下一站的量(因为在下一站加的油花的钱更少)
-加满能到达但是没有比此站油价更低的加油站,如果存在,将油加满(因为下一站油价更高而且满油的情况下从此站出发找不到油价更低的站了)
-加满都不能到达的,打印到最远距离
代码如下:

#include <iostream>
#include <string>
#include <algorithm>
#include <stdio.h>
using namespace std;
typedef struct{
    float price;
    float distance;
}Station;
int CM,D,DA,N;
bool compare(const Station &s1,const Station &s2){
    return s1.distance<s2.distance;
}
int main()
{
    cin>>CM>>D>>DA>>N;
    Station s[N+1];
    for(int i=0;i<N;i++){
        cin>>s[i].price>>s[i].distance;
    }
    s[N].price=0;
    s[N].distance=D;
    sort(s,s+N+1,compare);
    float allPrice=0;
    float maxDriveDistance=CM*DA;
    float nowGas=0;
    if(s[0].distance!=0){
        printf("The maximum travel distance = %.2f\n",0);
        return 0;
    }
    for(int i=0;i<N;){
        //不能到达下一个加油站
        if((s[i+1].distance-s[i].distance)>maxDriveDistance){
            printf("The maximum travel distance = %.2f\n",s[i].distance+maxDriveDistance);
            return 0;
        }
        Station next=s[i];
        int nextNumber=i;
        for(int j=i+1;j<N+1;j++){
            //找出能到达的更低的加油站
            if((s[j].distance-s[i].distance)<=maxDriveDistance&&s[j].price<next.price){
                next=s[j];
                nextNumber=j;
                break;
            }
        }
        //未找到更低的加油站
        if(nextNumber==i){
            next=s[i+1];
            nextNumber=i+1;
            for(int j=i+1;j<N+1;j++){
                //找出能到达的最低的加油站
                if((s[j].distance-s[i].distance)<=maxDriveDistance&&s[j].price<next.price){
                    next=s[j];
                    nextNumber=j;
                }
            }
            //加满
            allPrice+=(CM-nowGas)*s[i].price;
            nowGas=CM;
        }else{
            //加到能够到达下一个站的油量
            //油不够
            if(nowGas<(next.distance-s[i].distance)/DA){
                allPrice+=((next.distance-s[i].distance)/DA-nowGas)*s[i].price;
                nowGas=(next.distance-s[i].distance)/DA;
            }
        }
        nowGas-=(next.distance-s[i].distance)/DA;
        i=nextNumber;
    }
    printf("%.2f\n",allPrice);
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 215,539评论 6 497
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,911评论 3 391
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 161,337评论 0 351
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,723评论 1 290
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,795评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,762评论 1 294
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,742评论 3 416
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,508评论 0 271
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,954评论 1 308
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,247评论 2 331
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,404评论 1 345
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,104评论 5 340
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,736评论 3 324
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,352评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,557评论 1 268
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,371评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,292评论 2 352

推荐阅读更多精彩内容