Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<2147483648).
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2 1 2 2 2
Sample Output
NO YES
由于m和n都不确定大小,所以山洞根据轮询,可以看出如果两个的最大公约数大于1,就会导致循环。所以C代码如下,已通过。
#include "stdio.h"
int main()
{
int k,i;
scanf("%d",&k);
for(i=0; i < k; i++)
{
int m,n;
scanf("%d%d",&m,&n);
if(m == 1 && n == 1)
printf("NO\n");
else if(m == n)
printf("YES\n");
else if(m == 1 || n == 1)
printf("NO\n");
else
{
int c,a=m,b=n;
if(a < b)
{
c=a;
a=b;
b=c;
}
c=a%b;
while(c != 0)
{
a=b;
b=c;
c=a%b;
}
if(b == 1)
printf("NO\n");
else
printf("YES\n");
}
}
return 0;
}
测试数据:
/ *
1 1 NO
1 2 NO
2 2 YES
1 3 NO
2 3 NO
3 3 YES
1 4 NO
2 4 YES
3 4 NO
4 4 YES
1 5 NO
2 5 NO
3 5 NO
4 5 NO
5 5 YES
* /