题目描述
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^4 . The numbers in a line are separated by spaces.
Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.
Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
思路
1.关于行数、列数的求解
最接近n
的平方的两个整数一定是row-col
最小的两个整数。
2.关于矩阵的填充
填充的顺序是右下左上,由于vector的初始值为0且题目保证是正数,因此在一个周期内只需按照顺序判断即可。注意在往上填充的时候右边是空的,因此需要增设一个flag
,当flag
为1是才判断右方向。
代码
#include <iostream>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
bool cmp1(int a, int b) { return a > b; }
int main() {
int n, row, col, min = 99999999, r = 0, c = 0, cnt = 0, flag=1;
cin >> n;
vector<int> mat(n);
for (int i = 0; i < n; i++) cin >> mat[i];
for (col = sqrt((double)n); col >= 1; col--) {
if (n % col == 0) {
row = n / col;
break;
}
}
vector<vector<int>> ans(row, vector<int>(col));
sort(mat.begin(), mat.end(), cmp1);
while (cnt < n) {
ans[r][c] = mat[cnt];
if (c + 1 < col && ans[r][c + 1] == 0 && flag == 1) c++;
else if (r + 1 < row && ans[r + 1][c] == 0) r++;
else if (c - 1 >= 0 && ans[r][c - 1] == 0) c--;
else if (r - 1 >= 0 && ans[r - 1][c] == 0) {
r--;
if (r - 1 >= 0 && ans[r - 1][c] == 0) flag = 0;
else flag = 1;
}
cnt++;
}
for (int i = 0; i < row; i++) {
for (int j = 0; j < col; j++)
cout << (j == 0 ? "" : " ") << ans[i][j];
cout << endl;
}
return 0;
}