分解大质因数

参考博客
Description of the topic
In FZU ACM team, BroterJ and Silchen are good friends, and they often play some interesting games.
One day they play a game about GCD and LCM. firstly BrotherJ writes an integer A and Silchen writes an integer B on the paper. Then BrotherJ gives Silchen an integer X. Silchen will win if he can find two integers Y1 and Y2 that satisfy the following conditions:
• GCD(X, Y1) = A
• LCM(X, Y2) = B
• Fuction GCD(X, Y ) means greatest common divisor between X and Y .
• Fuction LCM(X, Y ) means lowest common multiple between X and Y .
BrotherJ loves Silchen so much that he wants Silchen to win the game. Now he wants to calculate how many number of X he can give to Silchen.

Input
Input is given from Standard Input in the following format:
A B
Constraints
1 ≤ A, B ≤ 10e18
Both A and B are integers.

Output
Print one integer denotes the number of X.

Sample input
3 12

Sample output
3
算法分析
假设c*A = X,d*x = B,我们的目标是求有多少个不同的x,换句话说就是求有多少个c或者d。c*d = B/A,c就是B/A的正约数。所以这道题就是求B/A的正约数个数。求正约数个数就是分解质因数。B/A的范围非常大。假设某个质数p>1e6,那么我可以断定B/A最多只包含两个大于1e6的质数。因为p*p*p>1e18。因此我们使用线筛求解1~1e7之间的质数,将B/A之间1e7以内的质因数分解求得结果ans。然后使用Miller-rabin算法判断剩余的数是一个质数,还是两个相同的质数,或者是两个不相同的质数。第一种情况答案就是2*ans,第二种情况答案是3*ans,第三种情况答案是4*ans。
代码中Miller-rabin的实现会误判。

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long LL;

LL a,b,kk;
LL prime[6] = {2, 3, 5, 233, 331};
LL gprime[10000005];
LL sum[100];
bool vis[10000005];
int cnt;
void primejudge()
{
    for(int i=2;i<10000005;i++)
    {
        if(!vis[i]) gprime[cnt++]=i;
        for(int k=0;k<cnt && i*gprime[k]<10000005;k++)
        {
            vis[i*gprime[k]]=true;
            if(i%gprime[k]==0) break;
        }
    }
}
LL qmul(LL x, LL y, LL mod)
{
    LL ret = 0;
    while(y) {
        if(y & 1)
            ret = (ret + x) % mod;
        x = x * 2 % mod;
        y >>= 1;
    }
    return ret;
}
LL qpow(LL a, LL n, LL mod)
{
    LL ret = 1;
    while(n)
    {
        if(n & 1)
            ret = qmul(ret, a, mod);
        a = qmul(a, a, mod);
        n >>= 1;
    }
    return ret;
}
bool Miller_Rabin(LL p)
{
    if(p < 2) return 0;
    if(p != 2 && p % 2 == 0) return 0;
    LL s = p - 1;
    while(! (s & 1)) s >>= 1;
    for(int i = 0; i < 5; ++i)
    {
        if(p == prime[i]) return 1;
        LL t = s, m = qpow(prime[i], s, p);
        while(t != p - 1 && m != 1 && m != p - 1)
        {
            m = qmul(m, m, p);
            t <<= 1;
        }
        if(m != p - 1 && !(t & 1)) return 0;
    }
    return 1;
}

LL Pollards_rho(LL x)
{
    int tot=1;
    LL ans=1;
    for(int i=0;gprime[i]*gprime[i]<=x && i<cnt ;i++)
    {
        if(x%gprime[i]==0)
        {
            while(x%gprime[i]==0)
            {
                x/=gprime[i];
                sum[tot]++;
            }
            tot++;
        }
        if(x==1) break;
    }
    for(int i=1;i<tot;i++) ans*=(sum[i]+1);
    if(x>1)
    {
        if(!Miller_Rabin(x))
        {
            LL tmp=sqrt(x);
            if(tmp*tmp==x) ans*=3;
            else ans*=4;
        }
        else ans*=2;
    }
    return ans;
}
int main()
{
    primejudge();
    scanf("%lld%lld",&a,&b);
    if (b%a)
    {
        printf("0\n");
        return 0;
    }
    kk=b/a;
    cout<<Pollards_rho(kk) << endl;
    return 0;
}


©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,544评论 6 501
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,430评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,764评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,193评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,216评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,182评论 1 299
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,063评论 3 418
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,917评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,329评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,543评论 2 332
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,722评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,425评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,019评论 3 326
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,671评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,825评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,729评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,614评论 2 353