1099.Build A Binary Search Tree

题目描述

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

考点

1.二叉树搜索;
2.遍历。

思路

1.我的思路(复杂)
首先根据输入构造二叉搜索树的结构,然后遍历出每个结点的左右子树所包含结点的个数。然后将输入的数组进行排序,根据左右子孙数便可定位每个结点应该放什么值。
2.柳神的思路
二叉搜索树中序遍历的结果就是由小到大排列的,因此将数组排序之后方可一一对应。
3.小结
我想的实在是有点复杂,归根究底应该是对二叉搜索树的性质不够熟悉。其中,对于输入的结点的排序,我和柳神都使用了c++中的sort函数。注意需要引入头文件#include <algorithm>

代码

1.我的代码(复杂版)

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
struct node {
    int val;
    int left, right;
    int lnum, rnum;
};
vector<node> bt;
vector<int> sq;
queue<int> q;
int n, c=0;
int calculate(int k) {
    if (bt[k].left == -1 && bt[k].right == -1) return 1;
    if (bt[k].left != -1) bt[k].lnum = calculate(bt[k].left);
    if (bt[k].right != -1) bt[k].rnum = calculate(bt[k].right);
    return bt[k].lnum + bt[k].rnum + 1;
}
void buildTree(int s, int e, int k) {
    if (s > e) return;
    bt[k].val = sq[s + bt[k].lnum];
    if (s == e)return;
    int t1 = s + bt[k].lnum - 1;
    if (bt[k].left != -1) buildTree(s, s + bt[k].lnum - 1, bt[k].left);
    if (bt[k].right != -1) buildTree(s+ bt[k].lnum + 1, e, bt[k].right);
}
void levelorder() {
    while (!q.empty()) {
        int t = q.front();
        c++; cout << bt[t].val << (c != n ? " " : "\n");
        q.pop();
        if (bt[t].left != -1)q.push(bt[t].left);
        if (bt[t].right != -1)q.push(bt[t].right);
    }
}
int main() {
    int i;
    cin >> n;
    bt.resize(n); sq.resize(n);
    for (i = 0; i < n; i++) {
        int a, b;
        cin >> a >> b;
        bt[i].left = a;
        bt[i].right = b;
        bt[i].lnum = 0;
        bt[i].rnum = 0;
    }
    for (i = 0; i < n; i++) {
        cin >> sq[i];
    }
    calculate(0);
    sort(sq.begin(), sq.end());
    buildTree(0, n-1, 0);
    q.push(0);
    levelorder();
    return 0;
}

2.完善版

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
struct node {
    int val;
    int left, right;
};
vector<node> bt;
vector<int> sq;
queue<int> q;
int n, c=0, t=0;
void inorder(int k) {
    if (bt[k].left == -1 && bt[k].right == -1) {
        bt[k].val = sq[t++];
        return;
    }
    if (bt[k].left != -1)inorder(bt[k].left);
    bt[k].val = sq[t++];
    if (bt[k].right != -1)inorder(bt[k].right);
}
void levelorder() {
    while (!q.empty()) {
        int t = q.front();
        cout << bt[t].val << ((++c) != n ? " " : "\n");
        q.pop();
        if (bt[t].left != -1)q.push(bt[t].left);
        if (bt[t].right != -1)q.push(bt[t].right);
    }
}
int main() {
    int i, a, b;
    cin >> n;
    bt.resize(n); sq.resize(n);
    for (i = 0; i < n; i++) {
        cin >> a >> b;
        bt[i].left = a;
        bt[i].right = b;
    }
    for (i = 0; i < n; i++) cin >> sq[i];
    sort(sq.begin(), sq.end());
    inorder(0);
    q.push(0);
    levelorder();
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 213,417评论 6 492
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,921评论 3 387
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 158,850评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,945评论 1 285
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,069评论 6 385
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,188评论 1 291
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,239评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,994评论 0 268
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,409评论 1 304
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,735评论 2 327
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,898评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,578评论 4 336
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,205评论 3 317
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,916评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,156评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,722评论 2 363
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,781评论 2 351

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,317评论 0 10
  • pyspark.sql模块 模块上下文 Spark SQL和DataFrames的重要类: pyspark.sql...
    mpro阅读 9,449评论 0 13
  • 毫厘间辗转腾挪 方寸中上下求索 成败前惟己不灭 生死后向阳而生 ——《都挺好》,随笔于19年初春夜,无喜无悲
    吴凡风之翼阅读 303评论 0 0
  • 当你来到我家里,走进我的房间,你便会被我写字台上的几支玻璃瓶里面的雨花石迷住。 你瞧,这颗红色石头上有一道弯曲的条...
    言念兼阅读 211评论 0 0
  • “春去冬来,酒比花香”,两句轻描淡写的描述,却道出了生态白酒舍得酒的酿造之道:一是年复一年储藏沉淀的优质基酒,二是...
    转角遇见酒阅读 399评论 0 2