There is a bag-like data structure, supporting two operations:
1 x Throw an element x into the bag.
2 Take out an element from the bag.
Given a sequence of operations with return values, you’re going to guess the data structure. It is
a stack (Last-In, First-Out), a queue (First-In, First-Out), a priority-queue (Always take out larger
elements first) or something else that you can hardly imagine!
Input
There are several test cases. Each test case begins with a line containing a single integer n (1 ≤ n ≤
1000). Each of the next n lines is either a type-1 command, or an integer 2 followed by an integer x.
That means after executing a type-2 command, we get an element x without error. The value of x
is always a positive integer not larger than 100. The input is terminated by end-of-file (EOF).
Output
For each test case, output one of the following:
stack It’s definitely a stack.
queue It’s definitely a queue.
priority queue It’s definitely a priority queue.
impossible It can’t be a stack, a queue or a priority queue.
not sure It can be more than one of the three data structures mentioned
above.
Sample Input
6
1 1
1 2
1 3
2 1
2 2
2 3
6
1 1
1 2
1 3
2 3
2 2
2 1
2
1 1
2 2
4
1 2
1 1
2 1
2 2
7
1 2
1 5
1 1
1 3
2 5
1 4
2 4
Sample Output
queue
not sure
impossible
stack
priority queue
WA了两次,忘记判断empty();
#include<cstdio>
#include<stack>
#include<queue>
using namespace std;
int main(){
int t;
while(scanf("%d", &t) != EOF){
int flag_s = 1, flag_q = 1, flag_p = 1;
stack<int>s;
queue<int>q;
priority_queue<int>p;
int a,b;
while(t--){
scanf("%d %d", &a, &b);
if(a == 1){
s.push(b);
q.push(b);
p.push(b);
}else{
if(flag_s){
if(!s.empty()){
int te = s.top();
s.pop();
if(te!=b){
flag_s = 0;
}
}else{
flag_s = 0;
flag_q = 0;
flag_p = 0;
continue;
}
}
if(flag_q){
if(q.front()!=b){
flag_q = 0;
}
q.pop();
}
if(flag_p){
if(p.top()!=b){
flag_p = 0;
}
p.pop();
}
}
}
if((flag_s&&flag_q)||(flag_s&&flag_p)||(flag_p&&flag_q)) printf("not sure\n");
else if(flag_s) printf("stack\n");
else if(flag_q) printf("queue\n");
else if(flag_p) printf("priority queue\n");
else printf("impossible\n");
}
return 0;
}