题目描述
Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤10^4) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 ... BK
where K is the number of birds in this picture, and Bi's are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10^4.
After the pictures there is a positive number Q (≤10^4) which is the number of queries. Then Q lines follow, each contains the indices of two birds.
Output Specification:
For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes
if the two birds belong to the same tree, or No
if not.
Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output :
2 10
Yes
No
考点
并查集
思路
1.判断鸟、树的个数
可以使用set,每输入一个鸟就将其插入到set中。最后直接利用set.size()
得到鸟的数量。鸟的数量确定之后,可以判断树的个数,树的个数也就是根的个数,循环所有鸟,存在父结点等于自身,则该结点为根结点。
2.并查集的使用注意
一开始find函数使用了递归造成了运行超时,因此后面改成了循环求解。
代码
#include <iostream>
#include <set>
using namespace std;
const int maxn=10001;
int parent[maxn];
int find(int x) {
int a = x;
while (x != parent[x])
x = parent[x];
while (a != parent[a]) {
int z = a;
a = parent[a];
parent[z] = x;
}
return x;
}
void toUnion(int x1, int x2) {
int r1 = find(x1), r2 = find(x2);
if(r1!=r2) parent[r1] = r2;
}
int main() {
int n, k, x, p, treenum=0, q, a, b;
cin >> n;
set<int> bird;
for (int i = 1; i <= maxn; i++) parent[i] = i;
for (int i = 0; i < n; i++) {
cin >> k >> p;
bird.insert(p);
for (int j = 0; j < k-1; j++) {
cin >> x;
bird.insert(x);
toUnion(p, x);
}
}
for (int i = 1; i <= bird.size(); i++) {
if (parent[i] == i)treenum++;
}
cout << treenum << " " << bird.size() << endl;
cin >> q;
for (int i = 0; i < q; i++) {
cin >> a >> b;
if (find(a) == find(b))cout << "Yes" << endl;
else cout << "No" << endl;
}
return 0;
}