source
Description
Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.
If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.
A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input
- Line 1: Two integers, N and M.
- Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output - Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4
Sample Output
1
2
3
4
2
1
4
3
2
4
1
题意:打印欧拉回路,这道题有Special judge,答案不唯一
题解:图的表示可以用链式前向星;遍历用DFS
#include <cstdio>
#include <string.h>
using namespace std;
const int V = 10010;
const int E = 100010;
int head[V],cnt;
struct Edge{
int to;
int next;
bool vis;
};
Edge edge[E];
void addEdge(int u,int v)
{
edge[cnt].to=v;
edge[cnt].next=head[u];
edge[cnt].vis=false;
head[u]=cnt++;
}
void DFS(int s)
{
for(int i=head[s];~i;i=edge[i].next)
{
if(!edge[i].vis)
{
edge[i].vis=true;
DFS(edge[i].to);
printf("%d\n",s);
}
}
}
int main(){
int n,m;
scanf("%d%d",&n,&m);
cnt=0;
memset(head, -1, sizeof(head));
int u,v;
for(int i=0; i<m; i++){
scanf("%d%d",&u,&v);
addEdge(u, v);
addEdge(v, u);
}
printf("1\n");
DFS(1);
return 0;
}