1017 Queueing at Bank (25分)
Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.
Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS
- the arriving time, and P - the processing time in minutes of a customer. Here HH
is in the range [00, 23], MM
and SS
are both in [00, 59]. It is assumed that no two customers arrives at the same time.
Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.
Output Specification:
For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.
Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
typedef struct person{
int come;
int time;
}person;
int cmp(person p1,person p2){
return p1.come<p2.come;
}
int main(){
person p[10010];
int n,k;
cin>>n>>k;
int hours,mintues,seconds,needs;
int count=0;
for(int i=0;i<n;++i){
scanf("%d:%d:%d %d",&hours,&mintues,&seconds,&needs);
int sum = hours*3600 + mintues*60 + seconds;
if(sum>61200)
continue;
p[count].time = needs*60;
p[count].come = sum;
count++;
}
sort(p,p+count,cmp);
priority_queue<int, vector<int>, greater<int> > q;//优先队列。从小到大排,队头元素是最小的。
for(int i=0;i<k;++i){//优先队列保存的是每个窗口能开始工作的最早时间,初始化为8点开始。
q.push(28800);
}
int total=0;
for(int i=0;i<count;++i){
//如果队头(k个窗口中最早可以开始工作)小于顾客到来的时间,那么直接服务。
if(q.top()<=p[i].come){
q.push(p[i].come + p[i].time);//压入新的节点。
q.pop();//原本的队头出队。
}else{
total += q.top() - p[i].come;//计算等待时间之和。
q.push(q.top() + p[i].time);//压入新节点(最早可以开始服务的时间)。
q.pop(); //弹出队头。
}
}
double result = total/60.0/count;
printf("%.1lf",result);
return 0;
}