PAT甲级1123-Is It a Complete AVL Tree(AVL树,层序遍历))

一.题目

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpg
F2.jpg
F3.jpg
F4.jpg

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.

Sample Input 1:

5
88 70 61 63 65

Sample Output 1:

70 63 88 61 65
YES

Sample Input 2:

8
88 70 61 96 120 90 65 68

Sample Output 2:

88 65 96 61 70 90 120 68
NO

二.题意

给定一个插入序列,判断是不是完全二叉树

三.代码部分

#include<bits/stdc++.h>
using namespace std;
struct node{//定义树形节点
    int val;
    struct node *left,*right;
};
node* leftRotate(node *tree){//左旋部分
    node *temp=tree->right;
    tree->right=temp->left;
    temp->left=tree;
    return temp;
}
node* rightRotate(node *tree){//右旋部分
    node *temp=tree->left;
    tree->left=temp->right;
    temp->right=tree;
    return temp;
}
node* LeftRightRotate(node *tree){//左右旋
    tree->left=leftRotate(tree->left);
    return rightRotate(tree);
}
node *RightLeftRotate(node *tree){//右左旋
    tree->right=rightRotate(tree->right);
    return leftRotate(tree);
}
int getHeight(node *tree){//得到树的高度
    if(tree==NULL)
        return 0;
    int l=getHeight(tree->left);
    int r=getHeight(tree->right);
    return max(l,r)+1;
}
node* insert(node *tree,int val){//树的插入部分
    if(tree==NULL){//树为空的情况
        tree=new node();
        tree->val=val;
    }else if(tree->val>val){//左子树进行插入
        tree->left=insert(tree->left,val);
        int l=getHeight(tree->left),r=getHeight(tree->right);
        if(l-r>=2){//如果左右高度相差为2
            if(val<tree->left->val)//如果小于树的左孩子,则进行右旋
                tree=rightRotate(tree);
            else//否则进行左右旋
                tree=LeftRightRotate(tree);
        }
    }else{//右孩子进行插入
        tree->right=insert(tree->right,val);
        int l=getHeight(tree->left),r=getHeight(tree->right);
        if(r-l>=2){//如果左右高度相差为2
            if(val>tree->right->val)//如果大于树的右孩子,则进行左旋
                tree=leftRotate(tree);
            else//否则进行右左旋
                tree=RightLeftRotate(tree);
        }
    }
    return tree;//返回树的结点
}
int isComplete=1,after=0;//iscomplete为标记是否是完全二叉树,after为标记左右情况
vector<int> levelOrder(node *tree){//层序遍历
    vector<int> v;
    queue<node *> queue;
    queue.push(tree);
    while(!queue.empty()){
        node *temp=queue.front();
        queue.pop();
        v.push_back(temp->val);
        if(temp->left!=NULL){//确保从上到下,从左到右为满树
            if(after)
                isComplete=0;
            queue.push(temp->left);
        }else{
            after=1;
        }
        if(temp->right!=NULL){
            if(after)
                isComplete=0;
            queue.push(temp->right);
        }else{
            after=1;
        }
    }
    return v;
}
int main(){
    int n,temp;
    cin>>n;
    node *tree=NULL;
    for(int i=0;i<n;i++){
        cin>>temp;
        tree=insert(tree,temp);//每次读入之后进行插入
    }
    vector<int> v=levelOrder(tree);//使用vector存储树的信息
    for(int i=0;i<v.size();i++){
        if(i!=0)
            cout<<" ";
        cout<<v[i];
    }
    printf("\n%s",isComplete?"YES":"NO");//是否是完全二叉树,进行输出
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 215,384评论 6 497
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,845评论 3 391
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 161,148评论 0 351
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,640评论 1 290
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,731评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,712评论 1 294
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,703评论 3 415
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,473评论 0 270
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,915评论 1 307
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,227评论 2 331
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,384评论 1 345
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,063评论 5 340
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,706评论 3 324
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,302评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,531评论 1 268
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,321评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,248评论 2 352

推荐阅读更多精彩内容