poj2431 Expedition

题目:

Description
A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input

  • Line 1: A single integer, N * Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. * Line N+2: Two space-separated integers, L and P
    Output
  • Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
    Sample Input
    4
    4 4
    5 2
    11 5
    15 10
    25 10
    Sample Output
    2

题意大概是给你要去的终点的距离以及初始的汽油,路上会有N个加油站,每个加油站都有相应的油可以加(汽车油桶无限大)。问到达终点站最少要加多少次油(如果无法到达,则输出-1)。

题目分类:贪心 & 优先队列。

此题可以用贪心法,由于要加最少次数,因此最好的情况就是到0时再加,而加油方式我们可以理解为先把油存起来,不够到下一个加油站了在加这些油,因此此题就是尽量先用加油的量多的油以减少中途的加油次数。因此我们可以用优先队列(最大堆的情况),油不够就取,如果队列为空还未到达终点就为-1.

注意:此题的距离是到终点的距离,另外需要先对距离排序(输入时可能无序)。

参考代码:

#include <iostream>
#include <queue>
#include <algorithm>
#include <cstring>
using namespace std;
struct xy {
    int loc;
    int units;
}a[10005];
bool cmp(xy a1,xy a2) {
    return a1.loc < a2.loc;
}
int main() {
    int n;
    int l,p;
    while (cin >> n) {
        memset(a,0,sizeof(a));
        for (int i = 0;i < n;++i) {
            cin >> a[i].loc >> a[i].units;
        }
        cin >> l >> p;
        for (int i = 0;i < n;++i) {
            a[i].loc = l - a[i].loc;
        }
        a[n].loc = l;//把终点也当做加油站;
        a[n++].units = 0;
        sort(a,a+n,cmp);
        priority_queue<int> que;
        int ans = 0,pos = 0,tank = p;
        for (int i = 0;i < n;++i) {
            int d = a[i].loc - pos;
            while (tank - d < 0) {
                if (que.empty()) {
                    cout << "-1" << endl;
                    return 0;
                }
                else {
                    ans++;
                    tank = tank + que.top();
                    que.pop();
                }
            }
            pos = a[i].loc;
            que.push(a[i].units);
            tank = tank - d;
        }
        cout << ans << endl;
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 217,509评论 6 504
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,806评论 3 394
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 163,875评论 0 354
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,441评论 1 293
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,488评论 6 392
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,365评论 1 302
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,190评论 3 418
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 39,062评论 0 276
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,500评论 1 314
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,706评论 3 335
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,834评论 1 347
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,559评论 5 345
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,167评论 3 328
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,779评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,912评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,958评论 2 370
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,779评论 2 354

推荐阅读更多精彩内容

  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,495评论 0 23
  • 古语有云:勿以善小而不为,勿以恶小而为之。大抵上很好的囊括了“小恶小善”的累积性和某一日的爆发性。对此我深以为然。...
    亦或然阅读 652评论 8 8
  • 继元旦第一次体验射箭之后,昨晚又去射箭,除了第一次体验到的新鲜和射中靶心的成就感之外,有了更多的一些体悟和收获。 ...
    杨一念阅读 1,500评论 5 4
  • 你走后风静止天空暗沉下来连远方的山也站立成一座悲伤的形状 你走后星坠落银河永恒失去浩瀚连深海的鱼也游弋成窒息的鱼肚...
    长亭怨慢阅读 369评论 10 26
  • 新西兰小学是四学期制,其中第四学期末和第一学期初为夏天,有游泳池的学校,便会开设游泳课。老实说,新西兰的夏天并不是...
    Aprilgao阅读 668评论 1 0