Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 322422 Accepted Submission(s): 76664
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
分析
这道题的题意是让你求最大子序列,这是一道动态规划里面的经典题目
在一次循环中动态更新最大值和起始下标与终止下标就可以实现啦。
//
// main.cpp
// hdu_acm
//
// Created by 翁一帆 on 2019/5/2.
// Copyright © 2019 mouweng. All rights reserved.
//
#include <iostream>
using namespace std;
int a[100000];
int main(int argc, const char * argv[]) {
int t;cin>>t;
for(int z=1;z<=t;z++){
int n;cin>>n;
for(int i=1;i<=n;i++){
cin>>a[i];
}
int maxNum=-1001;int tempNum=0;int bg=1,ed=1,temp=1;
for(int i=1;i<=n;i++){
tempNum+=a[i];
if(tempNum>maxNum){
maxNum=tempNum;
bg=temp;
ed=i;
}
if(tempNum<0){
tempNum=0;
temp=i+1;
}
}
cout<<"Case "<<z<<":"<<endl;
cout<<maxNum<<" "<<bg<<" "<<ed<<endl;
if(z!=t){
cout<<endl;
}
}
}