题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^5 ]), followed by N integer distances D1 D2 ⋯ DN , where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^4 ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^7 .
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
注意点
一般这种短小精悍的题都会卡时限,因此不要大意,一开始就要朝着缩短时间的思路去。cin
cout
的耗时远远大于scanf
printf
,因此如果有测试点通不过可以考虑改成scanf
printf
,在数据量较大的情况下,可以节省至少10ms。
代码
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
int n, m, sum = 0, a, b, ans = 0, temp;
scanf("%d", &n);
vector<int> dis(n + 1);
for (int i = 1; i <= n; i++) {
cin >> temp;
sum += temp;
dis[i] = sum;
}
scanf("%d", &m);
for (int i = 0; i < m; i++) {
scanf("%d %d", &a, &b);
if (a > b) swap(a, b);
temp = dis[b - 1] - dis[a - 1];
printf("%d\n", min(temp, sum - temp));
}
return 0;
}