题目
A crossword puzzle consists of a rectangular grid of black and white squares and two lists of definitions (or descriptions).
One list of definitions is for “words” to be written left to right across white squares in the rows and the other list is for words to be written down white squares in the columns. (A word is a sequence of alphabetic characters.)
To solve a crossword puzzle, one writes the words corresponding to the definitions on the white squares of the grid.
The definitions correspond to the rectangular grid by means of sequential integers on “eligible” white squares. White squares with black squares immediately to the left or above them are “eligible.” White squares with no squares either immediately to the left or above are also “eligible.” No other squares are numbered. All of the squares on the first row are numbered.
The numbering starts with 1 and continues consecutively across white squares of the first row, then across the eligible white squares of the second row, then across the eligible white squares of the third row and so on across all of the rest of the rows of the puzzle. The picture below illustrates a rectangular crossword puzzle grid with appropriate numbering.
An “across” word for a definition is written on a sequence of white squares in a row starting on a numbered square that does not follow another white square in the same row.
The sequence of white squares for that word goes across the row of the numbered square, ending immediately before the next black square in the row or in the rightmost square of the row.
A “down” word for a definition is written on a sequence of white squares in a column starting on a numbered square that does not follow another white square in the same column.
The sequence of white squares for that word goes down the column of the numbered square, ending immediately before the next black square in the column or in the bottom square of the column.
Every white square in a correctly solved puzzle contains a letter.
You must write a program that takes several solved crossword puzzles as input and outputs the lists of across and down words which constitute the solutions.
Input
Each puzzle solution in the input starts with a line containing two integers r and c (1 ≤ r ≤ 10 and 1 ≤ c ≤ 10), where r (the first number) is the number of rows in the puzzle and c (the second number) is the number of columns. The r rows of input which follow each contain c characters (excluding the end-of-line) which describe the solution. Each of those c characters is an alphabetic character which is part of a word or the character ‘*’, which indicates a black square. The end of input is indicated by a line consisting of the single number ‘0’.
Output
Output for each puzzle consists of an identifier for the puzzle (puzzle #1:, puzzle #2:, etc.) and the list of across words followed by the list of down words. Words in each list must be output one-per-line in increasing order of the number of their corresponding definitions. The heading for the list of across words is ‘Across’. The heading for the list of down words is ‘Down’. In the case where the lists are empty (all squares in the grid are black), the ‘Across’ and ‘Down’ headings should still appear.
Separate output for successive input puzzles by a blank line.
Sample Input
2 2
AT
*O
6 7
AIM*DEN
*ME*ONE
UPON*TO
SO*ERIN
*SA*OR*
IES*DEA
0
Sample Output
puzzle #1:
Across
1.AT
3.O
Down
1.A
2.TO
puzzle #2:
Across
1.AIM
4.DEN
7.ME
8.ONE
9.UPON
11.TO
12.SO
13.ERIN
15.SA
17.OR
18.IES
19.DEA
Down
1.A
2.IMPOSE
3.MEO
4.DO
5.ENTIRE
6.NEON
9.US
10.NE
14.ROD
16.AS
18.I
20.A
注:输出的数字标号占三个格子
我
常规输入两个数字,但结束时只输入一个数字。解决办法可以在while循环条件里写入先读入x,然后&&运算刚读入的x,然后循环体再读入y的值。还需要注意的是scanf不会清除输入y后的 '\n'。
其他地方和 UVa227 大同小异。
代码
#include <stdio.h>
#include <string.h>
#define MAXN 15
int main() {
char map[MAXN][MAXN];
int x, y;
int kase = 0;
while (scanf("%d", &x) && x)
{
scanf("%d", &y);
getchar();
for (int i = 0; i < x; i++)
fgets(map[i], MAXN, stdin);
int mark_r[MAXN * MAXN + 1][2];
int mark_c[MAXN * MAXN + 1][2];
for (int i = 0; i < MAXN * MAXN; i++) {
memset(mark_c[i], -1, sizeof(mark_c[i]));
memset(mark_r[i], -1, sizeof(mark_r[i]));
}
int n = 0;
for (int i = 0; i < x; i++) {
for (int j = 0; j < y; j++) {
if (map[i][j] != '*') {
if ((i - 1 < 0 || map[i - 1][j] == '*') && (j - 1 < 0 || map[i][j - 1] == '*')) {
mark_r[++n][1] = j;
mark_r[n][0] = i;
mark_c[n][1] = j;
mark_c[n][0] = i;
}
else if (i - 1 < 0 || map[i - 1][j] == '*') {
mark_r[++n][1] = j;
mark_r[n][0] = i;
}
else if (j - 1 < 0 || map[i][j - 1] == '*') {
mark_c[++n][1] = j;
mark_c[n][0] = i;
}
}
}
}
if (kase)
printf("\n");
printf("puzzle #%d:\n", ++kase);
printf("Across\n");
for (int i = 1; i <= x*y; i++) {
if (mark_c[i][0] != -1) {
printf("%3d.", i);
int m_y = mark_c[i][1];
int m_x = mark_c[i][0];
while (m_y < y && map[m_x][m_y] != '*')
printf("%c", map[m_x][m_y++]);
printf("\n");
}
}
printf("Down\n");
for (int i = 1; i <= x*y; i++) {
if (mark_r[i][0] != -1) {
printf("%3d.", i);
int m_y = mark_r[i][1];
int m_x = mark_r[i][0];
while (m_x < x && map[m_x][m_y] != '*')
printf("%c", map[m_x++][m_y]);
printf("\n");
}
}
}
return 0;
}