1003. Triangle Partition

1003. Triangle Partition

  • Time limit: 1 second
  • Memory limit: 32 megabytes
    Problem Description
    Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear. Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.
    Input
    There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case: The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct. Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109). It is guaranteed that the sum of all n does not exceed 10000.
    Output
    For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci ≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.
    Sample Input
    1 1 1 2 2 3 3 5
    Sample Output
    1 2 3

题意:给3n个任意三点不在同一直线上的点,找出n个不相交的三角形
标程思路:求个凸包,然后选择凸包一条边 ,然后找个和 夹角最小的点 ,把 当做一个三角形删掉即可。 这样做个n次,显然这样求出来的三角形们是合法的。

但实际上,满足不相交只要按照从左到右,从上到下的顺序删去点即可

标程:(凸包的代码我还没手动敲过 mark)

#include <cstdio>
#include <vector>

using int64 = long long;

struct point {
  int64 x, y;
  int i;
  point(int64 x = 0, int64 y = 0): x(x), y(y) {}
  point operator + (const point& rhs) const {
    return {x + rhs.x, y + rhs.y};
  }
  point operator - (const point& rhs) const {
    return {x - rhs.x, y - rhs.y};
  }
  int64 det(const point& rhs) const {
    return x * rhs.y - y * rhs.x;
  }
  int64 dot(const point& rhs) const {
    return x * rhs.x + y * rhs.y;
  }
};

const int N = 5e3 + 10;

point p[N];

int main() {
  int T;
  scanf("%d", &T);
  for (int cas = 1; cas <= T; ++cas) {
    int n;
    scanf("%d", &n);
    n *= 3;
    for (int i = 0; i < n; ++i) {
      scanf("%lld%lld", &p[i].x, &p[i].y);
      p[i].i = i + 1;
    }
    for (int it = 0; it < n / 3; ++it) {
      int m = n - it * 3;
      int a = 0, b = -1, c = -1;
      // lowest point p_a
      for (int i = 1; i < m; ++i) {
        if (p[i].y < p[a].y || (p[i].y == p[a].y && p[i].x < p[a].x)) a = i;
      }
      // right most point p_b
      for (int i = 0; i < m; ++i) if (i != a) {
        if (b == -1 || (p[b] - p[a]).det(p[i] - p[a]) < 0) b = i;
      }
      // second right most point p_c
      for (int i = 0; i < m; ++i) if (i != a && i != b) {
        if (c == -1 || (p[c] - p[a]).det(p[i] - p[a]) < 0) c = i;
      }
      printf("%d %d %d\n", p[a].i, p[b].i, p[c].i);
      for (int i = 0, j = 0; i < m; ++i) if (i != a && i != b && i != c) {
        p[j++] = p[i];
      }
    }
  }
  return 0;
}

比赛代码:

//B17040312
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

struct point{
    int x;
    int y;
}p[30005];

int pos[30005];

bool cmp(int a , int b){
    if(p[a].x<p[b].x) return true;
    else if(p[a].x>p[b].x) return false;
    else{
        return p[a].y<p[b].y;
    }
}

int main(){
    int t,n;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        for(int i = 0; i < 3*n; i++){
            scanf("%d %d", &p[i].x,&p[i].y);
            pos[i] = i;
        }
        sort(pos, pos+3*n, cmp);
        for(int i = 0; i < 3*n; i++){
            printf("%d", pos[i]+1);
            if((i+1)%3==0&&i!=3*n-1) printf("\n");
            else printf(" ");
        }
    }
    return 0;
} 
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,837评论 6 496
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,551评论 3 389
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 160,417评论 0 350
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,448评论 1 288
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,524评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,554评论 1 293
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,569评论 3 414
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,316评论 0 270
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,766评论 1 307
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,077评论 2 330
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,240评论 1 343
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,912评论 5 338
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,560评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,176评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,425评论 1 268
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,114评论 2 366
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,114评论 2 352