2016微软探星 | Full Binary Tree Picture

承接上一篇文章,题目同样来自2016微软探星夏令营在线技术笔试。这道题主要考察的是树的构建与遍历。


题目:
时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述
Let's draw a picture of full binary tree using ASCII characters. In this picture nodes are represented by '#'. A parent node connects its left child by '/' and its right child by ''.
For the sake of aesthetic, the nodes of the same height must be painted on the same line. And the nodes must be perfectly connected by '/' and ''. Intersections or misplacements are not allowed.
For example, this is the full binary tree of height 2:

  # 
 / \
#  #

This is the full binary tree of height 3:

   #
  / \
 /   \
 #    #
/ \  / \
#  # # #

This is the full binary tree of height 4:

        # 
       / \
      /   \
     /     \
    /       \
   /         \ 
   #         # 
  / \       / \ 
 /   \     /   \ 
 #   #     #    # 
/ \ / \    / \  / \
# # # #    # #  # #

Now we build a Cartesian coordinate system for the picture. We make the root at the origin (0, 0). The positive direction of x is to the bottom and the positive direction of y is to the right.
The full binary tree of height 2 is illustrated as below.

0 
+-----+--------> y
|
0+    #(0,0)
|    / \
|   #   # 
|(2,-2) (2,2)
| 
v
x

Given the height of the tree and a rectangle area of the picture, your task is to find out the amount of nodes in such area. For example, assuming the height of tree is 2, the left-top corner of the rectangle area is at (0, 0) and the right-bottom corner is at (2, 2), then the area contains 2 nodes (the root and its right child) totally.
输入
The first line contains two integers N and M.
N is the height of the full binary tree. M is the number of queries. (1 ≤ N≤ 20, 1 ≤ M≤ 100)Each query consists of 4 integers x1, y1, x2 and y2. (x1, y1) is the left-top corner of the area and (x2,y2) is the right-bottom corner of the area.
输出
For each query output the amount of nodes in the area.

样例输入

2 3
0 0 0 0
0 0 2 2
0 -2 2 2

样例输出

1

2
3

解释:
题目描述了一种用ASCII码绘制的满二叉树,然后将树的根设置在一个特殊坐标轴的原点(0,0),坐标轴x向下为正向,y向右是正向。树的每个树枝与节点都占用1*1的大小。现在需要求在坐标轴中任意画一个矩形,里面会有多少个树的节点。例如样例输入中,对于(0,0)与(2,2)形成的矩形里面,包含有根节点和它的右叶子节点,所以输出的是2。

分析:
1、这是是一个二叉树的问题,肯定要构造树结构,为了简单,这里就声明一个Node的结构体,通过结构体指针来构建树。代码如下:

struct Node {
    Node *lchild, *rchild;
    long px, py;
    Node(long _px, long _py)
    {
        lchild = rchild = NULL;
        px = _px;
        py = _py;
    }
};

px,py是节点的坐标,lchild与rchild分别对应左右子节点。

2、接下里就是生成树,这里输入就是树的高度,我们就根据高度来生成满二叉树。生成的时候根据题目规则,我们需要注意树的树枝占位情况。通过分析我们可以得出,高度为1的节点,它一边的树枝数量是0,高度2的为1,高度3的为2,其它高度的节点树枝数量是其子节点数量的2倍加1。这样我们可以用个递归实现。代码如下:

long stickNumWithHeight(int height)
{
    if (height == 1) {
        return 0;
    }
    if (height == 2) {
        return 1;
    }
    if (height == 3) {
        return 2;
    }
    return stickNumWithHeight(height - 1) * 2 + 1;
}

void buildTreeWithHeight(Node &node, int height)
{
    if (height == 1) {
        return;
    }
    long step = stickNumWithHeight(height) + 1;
    node.lchild = new Node(node.px + step, node.py - step);
    node.rchild = new Node(node.px + step, node.py + step);
    buildTreeWithHeight(*node.lchild, height-1);
    buildTreeWithHeight(*node.rchild, height-1);
}

3、树生成过后,我们只需要对每个矩形遍历检测这棵树,就可得到在当前矩形中节点数量,代码如下:

int checkNodeInArea(Node &node, int x1, int y1, int x2, int y2)
{
    int sum = 0;
    if (node.px >= x1 && node.py >= y1 && node.px <= x2 && node.py<= y2) {
        sum += 1;
    }
    if (node.lchild != NULL) {
        sum += checkNodeInArea(*node.lchild,x1,y1,x2,y2);
    }
    if (node.rchild != NULL) {
        sum += checkNodeInArea(*node.rchild,x1,y1,x2,y2);
    }
    return sum;
}

判定结果:


完整代码:

//
//  main.cpp
//  Full Binary Tree Picture
//
//  Created by Jiao Liu on 8/5/16.
//  Copyright © 2016 ChangHong. All rights reserved.
//

#include <iostream>
#include <math.h>

using namespace std;

struct Node {
    Node *lchild, *rchild;
    long px, py;
    Node(long _px, long _py)
    {
        lchild = rchild = NULL;
        px = _px;
        py = _py;
    }
};

long stickNumWithHeight(int height)
{
    if (height == 1) {
        return 0;
    }
    if (height == 2) {
        return 1;
    }
    if (height == 3) {
        return 2;
    }
    return stickNumWithHeight(height - 1) * 2 + 1;
}

void buildTreeWithHeight(Node &node, int height)
{
    if (height == 1) {
        return;
    }
    long step = stickNumWithHeight(height) + 1;
    node.lchild = new Node(node.px + step, node.py - step);
    node.rchild = new Node(node.px + step, node.py + step);
    buildTreeWithHeight(*node.lchild, height-1);
    buildTreeWithHeight(*node.rchild, height-1);
}

int checkNodeInArea(Node &node, int x1, int y1, int x2, int y2)
{
    int sum = 0;
    if (node.px >= x1 && node.py >= y1 && node.px <= x2 && node.py<= y2) {
        sum += 1;
    }
    if (node.lchild != NULL) {
        sum += checkNodeInArea(*node.lchild,x1,y1,x2,y2);
    }
    if (node.rchild != NULL) {
        sum += checkNodeInArea(*node.rchild,x1,y1,x2,y2);
    }
    return sum;
}

int main(int argc, const char * argv[]) {
    int N,M;
    scanf("%d %d",&N,&M);
    Node *root = new Node(0,0);
    buildTreeWithHeight(*root,N);
    while (M--) {
        int x1,y1,x2,y2;
        scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
        int amout = checkNodeInArea(*root,x1,y1,x2,y2);
        cout<<amout<<endl;
    }
    return 0;
}

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 213,864评论 6 494
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,175评论 3 387
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,401评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,170评论 1 286
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,276评论 6 385
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,364评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,401评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,179评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,604评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,902评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,070评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,751评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,380评论 3 319
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,077评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,312评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,924评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,957评论 2 351

推荐阅读更多精彩内容

  • 人,从某个不经意的瞬间悄悄地来,在某个难以预料的时刻轻轻的去,这来去的中间,有多少有用或无用的东西在内心流淌...
    悄然Edward阅读 321评论 0 7
  • 1.如何让人感觉我的商品很好? 问:大湿,如何让人感觉我的商品很好?答:贵一点。问:哦,你的意思是说好贵好贵,好才...
    徐克惜愚兄弟阅读 407评论 0 0
  • 我钻进一条山洞,去寻找我自以为是的夜空。可是 黑暗中只有花香浓,冻结成了每一寸时空,连飞蛾的振翅和蝙蝠的扑声也那么...
    李一十八阅读 264评论 0 1
  • 1、道歉:并不总意味着你是错的,它只是意味着你更珍惜你们之间的关系。 2、专一:不是一辈子只喜欢一个人,是喜欢一个...
    医成道人阅读 191评论 0 0