1010 Radix (25)

题目信息

1010 Radix (25)(25 分)
Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.
Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.
Input Specification:
Each input file contains one test case. Each case occupies a line which contains 4 positive integers:\ N1 N2 tag radix\ Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.
Output Specification:
For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible

代码

#include<iostream>
#include<cctype>
using namespace std;
long long to_decimal(string s,long long radix){
    long long sum=0;
    for(int i=0;i<s.length();i++){
        sum=sum*radix;
        if(isdigit(s[i])) sum+=s[i]-'0';
        if(isalpha(s[i])) sum+=s[i]-'a'+10;
    }
    return sum;
}
long long find_left(string s){
    int max=0;
    for(int i=0;i<s.length();i++){
        if(isdigit(s[i])&&s[i]-'0'>max) max=s[i]-'0';
        if(isalpha(s[i])&&s[i]-'a'+10>max) max=s[i]-'a'+10;
    }
    return max;
}
long long binarySearch(string s,long long left,long long right,long long dec){
    long long mid,s_dec;
    while(left<=right){
        mid=(left+right)/2;
        s_dec=to_decimal(s,mid);
        if(s_dec<0||s_dec>dec) right=mid-1;//若转换后的十进制数溢出(一定是radix选大了)或较大 
        else if(s_dec<dec) left=mid+1;//选小了 
        if(s_dec==dec) return mid;//返回此时的mid即为最终所找的radix 
    }
    return -1;
}
int main(){
    string n1,n2;
    long long tag,radix,dec1,dec2,flag;
    cin >> n1 >> n2 >> tag >> radix;
    if(tag==1){
        dec1=to_decimal(n1,radix);
        long long left=find_left(n2);
        flag=binarySearch(n2,left+1,dec1+1,dec1);
    }else{
        dec2=to_decimal(n2,radix);
        long long left=find_left(n1);
        flag=binarySearch(n1,left+1,dec2+1,dec2);
    }
    if(flag==-1) cout<<"Impossible";
    else cout<<flag;
    return 0;
} 

测试结果

image.png
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,029评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,238评论 3 388
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,576评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,214评论 1 287
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,324评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,392评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,416评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,196评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,631评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,919评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,090评论 1 342
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,767评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,410评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,090评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,328评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,952评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,979评论 2 351

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,319评论 0 10
  • 我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。...
    OliverLew阅读 508评论 0 0
  • 我们如何去理解云联电器?如何去分享发展云联电器? 相信自己999 已关注 2018-03-21 22:27 · 字...
    牟姐姐2030阅读 102评论 0 0
  • 《我要跟自信》这本书,写的是让我们要更加自信的许多故事,和让我们怎么做。 像《草叶集》的作者惠特曼,就是因为自信和...
    皮卡丘萌萌哒阅读 2,584评论 2 0
  • 2017.10.17晚22:15下班后一如往常先烧一桶水然后…… 静静的听着[书房]靠在床边,手里拿着本[白夜行]...
    帅啊宁阅读 291评论 0 0