题目描述
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9
Sample Output 2:
Heap Sort
5 4 3 1 0 2 6 7 8 9
考点
插入排序、堆排序
思路
1.判断是哪种排序
插入排序的前n
项一定是由小到大排列的,剩余的项保持原来的位置。因此只需判断出插入排序,否则就是堆排序。
2.再进行一次排列
插入排序:将n+1
项重排即可;
堆排序:后n
项是按照由小到大的顺序排列好的,前n
项是最大堆,因此将最后一个结点与根结点相交换然后再向下调整一次即可。
代码
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
void downAdjust(vector<int> &sq2,int low, int high) {
int i = 1, j = i * 2;
while (j <= high) {
// has right
if (j + 1 <= high&&sq2[j] < sq2[j + 1]) j = j + 1;
if (sq2[i] >= sq2[j]) break;
swap(sq2[i], sq2[j]);
i = j; j = i * 2;
}
}
int main() {
int n, p=2;
cin >> n;
vector<int> sq1(n + 1), sq2(n + 1);
for (int i = 1; i <= n; i++) cin >> sq1[i];
for (int i = 1; i <= n; i++) cin >> sq2[i];
while (p <= n&&sq2[p] >= sq2[p - 1]) p++;
int index = p;
while (p <= n&&sq1[p] == sq2[p]) p++;
if (p == n + 1) {
cout << "Insertion Sort\n";
sort(sq2.begin() + 1, sq2.begin() + index + 1);
}
else {
cout << "Heap Sort\n";
p = n;
while (p >= 2 && sq2[p] >= sq2[1]) p--;
swap(sq2[1], sq2[p]);
downAdjust(sq2, 1, p - 1);
}
for (int i = 1; i <= n; i++)
cout << (i == 1 ? "" : " ") << sq2[i];
return 0;
}