1047 Student List for Course (25 分)(排序)

1047 Student List for Course (25 分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses. Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

分析:

本题结题思路较为常规,属于简单题,但是最后一个测试点容易运行超时或者运行超限,<font color="hotpink">一般处理运行超时的方式优先会将程序中所有的输入和输出换成C语言对应的输入和输出,scanf/printf,这个会比cin/cout耗时少,但是依然不奏效源代码1超时测试点依然没通过。</font>参考博客[1]修改源代码1。解法较简单,此处不赘述,本分析旨在测试点超时的问题,从源代码2中我们似乎可以分析出程序处理int类型的时间要比string或者字符数组(e.g. char * name])的时间要长。

<font color="#6CB23B">小结:运行超时问题
1.采用scanf、printf输入输出;
2.以时间换空间,降低时间复杂度,特别地,在查询操作中,时间复杂度可以由O(N)降低为O(1);
3.处理字符串比处理整型数要耗时,一般通过hash散列将字符串映射成整型数,通过直接处理整型数间接处理字符串,这条结论不知道成不成立,但是在此题奏效。</font>
源代码2

#include<iostream>
#include <vector>
#include <algorithm>
#include <cstring>
using namespace std;
char name[40010][5];
bool cmp(int a,int b){
    if(strcmp(name[a],name[b])<0) return true;
    else return false;
}
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
    vector<vector<int> > v(n+1);
    for(int i=0;i<n;i++){
        scanf("%s",name[i]);                
        int cnt;
        scanf("%d",&cnt);
        for(int j=0;j<cnt;j++){
            int k;
            scanf("%d",&k);
            v[k].push_back(i);
        }
    }
    for(int i=1;i<=k;i++){
        printf("%d %d\n",i,(int)v[i].size());
        sort(v[i].begin(),v[i].end(),cmp);
        for(auto it : v[i]) {
            printf("%s\n",name[it]);
        }
    }
    return 0;
} 

源代码1

#include<iostream>
#include <vector>
#include <set>
#include <cmath>
using namespace std;
int main(){
    int n,k;
    scanf("%d %d",&n,&k);
    vector<set<int> > v(n+1);
    for(int i=0;i<n;i++){
        char name[5];
        scanf("%s",name);
        int name_int=0;
        for(int i=0;i<=3;i++){
            name_int = name_int*100+name[i];
        }                   
        int cnt;
        scanf("%d",&cnt);
        for(int j=0;j<cnt;j++){
            int k;
            scanf("%d",&k);
            v[k].insert(name_int);
        }
    }
    for(int i=1;i<=k;i++){
        printf("%d %d\n",i,(int)v[i].size());
        for(auto it : v[i]) {
            char name[5];
            for(int i=0;i<=3;i++){
                int tmp=(int)pow(100,3-i);
                name[i]=it/tmp;
                it%=tmp;
            }
            printf("%s\n",name);
        }
    }
    return 0;
} 

  1. https://www.liuchuo.net/archives/2147

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,491评论 5 459
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,856评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,745评论 0 319
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,196评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,073评论 4 355
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,112评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,531评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,215评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,485评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,578评论 2 309
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,356评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,215评论 3 312
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,583评论 3 299
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,898评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,174评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,497评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,697评论 2 335

推荐阅读更多精彩内容