ACM 之 C - Dungeon Master

原题链接poj

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). L is the number of levels making up the dungeon. R and C are the number of rows and columns making up the plan of each level. Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. If it is not possible to escape, print the line

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#
#####
#####
##.##
##...
#####
#####
#.###
####E
1 3 3
S##
#E#
###
0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

理解

这道题是三维地图广搜,我做这道题的时候遇到了很多麻烦:
一、开始用的深搜以为自己没错一直改改改,后来在学长的提醒下用bfs重新
写了;
二、虽然不是大问题,但是在输入的时候换行符的格式要注意,记得用getchar()吃掉;
三、也是最重要的一点!!每个可行的分支在进入队列的时候一定要状态标记它!!不然会重复运行导致超时。

代码部分

#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
char map[31][31][31],cc;
int s1,s2,s3,x,y,z,a,b,c,finde,sum,fla[31][31][31];
struct node
{
    int x,y,z;
};
queue<node>S;
node chan[6]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
int main()
{
    while(scanf("%d%d%d",&a,&b,&c)&&a&&b&&c)
    {
        getchar();//吃换行符
        memset(fla,0,sizeof(fla));
        memset(map,'#',sizeof(map));//数据清空
        for(int i=0;i<a;i++)
        {   for(int j=0;j<b;j++)
            {   for(int k=0;k<c;k++)
                {
                    scanf("%c",&map[i][j][k]);//地图输入
                    if(map[i][j][k]=='.'||map[i][j][k]=='E')
                        fla[i][j][k]=-1;
                    if(map[i][j][k]=='S')
                    {
                        s1=i;s2=j;s3=k;
                    }
                }getchar();
            }getchar();
        }
        node thes;
        thes.x=s1;thes.y=s2;thes.z=s3;
        while(!S.empty())//队列清空
        {
            S.pop();
        }
        node count={-1,0,0};
        S.push(count);
        S.push(thes);
        sum=-1;finde=0;
        while(S.size()>1)//循环搜索出口
        {
            if(S.front().x == -1){ sum++; S.push(S.front()); S.pop(); }//层数标记
            x = S.front().x; y = S.front().y; z = S.front().z;
            if(map[x][y][z]=='E'){finde=1;break;}
            node si;
            for(int kk=0;kk<6;kk++)
            {
                if(fla[x+chan[kk].x][y+chan[kk].y][z+chan[kk].z]==-1)
                {
                    si.x=x+chan[kk].x;
                    si.y=y+chan[kk].y;
                    si.z=z+chan[kk].z;
                    S.push(si);
                    fla[x+chan[kk].x][y+chan[kk].y][z+chan[kk].z]=1;//一定要在这里标记它!不然就可能超时。
                }
            }
            S.pop();
        }
        if(finde==1)
        {
            printf("Escaped in %d minute(s).\n",sum);
        }
        else
            printf("Trapped!\n");
    }
    return 0;
}

意见反馈 || 任何建议

联系我(新浪)
邮箱:qianlizhihao@gmail.com

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,921评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 87,635评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,393评论 0 338
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,836评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,833评论 5 368
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,685评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,043评论 3 399
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,694评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 42,671评论 1 300
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,670评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,779评论 1 332
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,424评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,027评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,984评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,214评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,108评论 2 351
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,517评论 2 343

推荐阅读更多精彩内容

  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,372评论 0 23
  • 《乌合之众》以十八世纪欧洲战争为背景,分析当时作为主体参战的群众,他们的心理特征,借以表达对法国民族文明的失望与不...
    0121af403f65阅读 541评论 0 0
  • 像园子里最后一串葡萄 挂在藤间,缄默着不开口 雨一直下 一群雨邀约着另一群雨 不顾天地只管下 这样的天气 适合想一...
    一只玻璃鱼阅读 190评论 0 3
  • 2016年年末的午餐是和孩子的婆婆爷爷、外公外婆、小姨小姨爹一起吃的,餐后送了婆婆爷爷回家,爸爸也去办事,只...
    千吉change阅读 168评论 0 0
  • 说这些问题,未免有点政治化,但是人是一个大的家庭的一个元素,逃离不了这个问题。人类社会的演变是一个充满血腥的过程,...
    佛禅善心阅读 188评论 0 1