02-线性结构3 Reversing Linked List

02-线性结构3 Reversing Linked List (25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given Lbeing 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4

00000 4 99999

00100 1 12309

68237 6 -1

33218 3 00000

99999 5 68237

12309 2 33218

Sample Output:

00000 4 33218

33218 3 12309

12309 2 00100

00100 1 99999

99999 5 68237

68237 6 -1

Code:


#include <stdio.h>

#define MAX 100000

typedef struct{

    int data;

    int next;

}Node;

//计算在数组中的元素个数

int CountNum(Node *list,int plist);

//反转元素

int Reverse(Node *list,int num,int plist,int k);

//打印元素

void Print(Node *list,int plist);

int main(){

    Node list[MAX];

    int plist,n,k;

    scanf("%d%d%d",&plist,&n,&k);

    int addr,data,next;

    while(n>0){

        scanf("%d%d%d",&addr,&data,&next);

        list[addr].data=data;

        list[addr].next=next;

        n--;

    }

    int num=CountNum(list,plist);

    int newplist=Reverse(list,num,plist,k);

    Print(list,newplist);

    return 0;

}

int Reverse(Node *list,int num,int plist,int k){

    int preNode,curNode,nextNode;

    preNode=-1;

    curNode=plist;

    nextNode=list[curNode].next;

    int head=-1,lasthead;

    for (int i=0;i<num/k;i++){

        lasthead=head;

        head=curNode;

        for(int j=0;j<k;j++){

            list[curNode].next=preNode;

            preNode=curNode;

            curNode=nextNode;

            nextNode=list[curNode].next;

        }

        if (i==0) plist=preNode;

        else list[lasthead].next=preNode;

    }

    list[head].next = curNode; //不用逆转的剩余部分加上

    return plist;

}

int CountNum(Node *list,int plist){

    int c=1;

    while((plist=list[plist].next)!=-1) c++;

    return c;

}

void Print(Node *list,int plist){

    while((list[plist].next)!=-1){

        printf("%05d %d %d\n",plist,list[plist].data,list[plist].next);

        plist = list[plist].next;

    }

    printf("%05d %d %d\n",plist,list[plist].data,list[plist].next);

}

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 212,686评论 6 492
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 90,668评论 3 385
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 158,160评论 0 348
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 56,736评论 1 284
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 65,847评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,043评论 1 291
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,129评论 3 410
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,872评论 0 268
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,318评论 1 303
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,645评论 2 327
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,777评论 1 341
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,470评论 4 333
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,126评论 3 317
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,861评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,095评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 46,589评论 2 362
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 43,687评论 2 351

推荐阅读更多精彩内容

  • pyspark.sql模块 模块上下文 Spark SQL和DataFrames的重要类: pyspark.sql...
    mpro阅读 9,448评论 0 13
  • 走得时候 说什么都是多余 所有情绪都在目光里 而你 连头也没抬
    居戎阅读 313评论 0 0
  • 昨晚孩子又像往常一样,在临睡前到我房间里跟我聊天。昨晚聊的是MC的制作流程。整个制作过程足足讲了半个小时,...
    水到渠成111阅读 143评论 0 0
  • 一、利:1、民族自信力 2、在诗歌中寻找远方,鼓励自我,淡然面对。 3、纵向传承,知道文化的源头,与知识更好地融合...
    囚歌歌歌阅读 365评论 0 0
  • 经常,读了关于爱情的文章之后我总会觉得很孤独。因为是单身久了,看到了情侣的甜蜜和单身者的自白我都会被触动。我觉得我...
    洒落的阳光阅读 92评论 0 1