02-线性结构3 Reversing Linked List

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

My Code

#include<stdio.h>
int main()
{
    int address,faddress,data,next,n,k,i,j,count,sum=0;
    scanf("%d %d %d",&faddress,&n,&k);
    int link[n][3];
    for(i=0; i<n; i++){  //读取数据 
        scanf("%d %d %d",&address,&data,&next);
        link[i][0] = address;
        link[i][1] = data;
        link[i][2] = next;
    }
    int tmpad,tmpda,tmpne,ne=faddress;
    for(i=0; i<n; i++){  //让数据在数组中按照顺序存放 
        for(j=i; j<n; j++){
            if(link[j][0] == ne){
                count = j;
                break;
            }
        }
        ne = link[count][2];sum = sum + 1;  //sum是为了去除多余的,并不在链表里面的结点 
        tmpad = link[i][0];tmpda = link[i][1];tmpne = link[i][2];
        link[i][0] = link[count][0];link[i][1] = link[count][1];link[i][2] = link[count][2];
        link[count][0] = tmpad;link[count][1] = tmpda;link[count][2] = tmpne;
        if(ne==-1) break;
    }
    int newlink[sum][3];
    for(i=sum; i>=1; i--){  //按照要求逆序存放,此时只对链表中的结点进行操作 
        if(i%k==0){
            for(j=1; j<k; j++){
                newlink[(i/k-1)*k+j-1][0] = link[i-j][0];
                newlink[(i/k-1)*k+j-1][1] = link[i-j][1];
                newlink[(i/k-1)*k+j-1][2] = link[i-j-1][0];
            }
            newlink[(i/k-1)*k+k-1][0] = link[i-k][0];
            newlink[(i/k-1)*k+k-1][1] = link[i-k][1];
            if(i==sum) newlink[(i/k-1)*k+k-1][2] = -1;
            else newlink[(i/k-1)*k+k-1][2] = newlink[i][0];
        }
        if(i%k!=0 && i==sum){
            for(j=1;j<=i%k;j++){
                newlink[i-j][0] = link[i-j][0];
                newlink[i-j][1] = link[i-j][1];
                if(j==1) newlink[i-j][2] = -1;
                else newlink[i-j][2] = link[i-j][2];
            }
        }
    }
    for(i=0;i<sum-1;i++) printf("%05d %d %05d\n",newlink[i][0],newlink[i][1],newlink[i][2]);
    printf("%05d %d -1\n",newlink[sum-1][0],newlink[sum-1][1]);
    return 0;
} 

outcome

outcome

thoughts

这个题目实际上并不是特别难,我是独立完成整个题目的,但是值得注意的是需要注意很多细节,不然很多测试点都无法通过,并且要注意算法的时间与空间复杂度,由于N的最大值可以取到10^5,如果算法太过于暴力肯定是不行的,实际上我的这个算法就稍微有一点暴力了,只要去掉其中一句关键用于减少时间复杂度的语句就会不通过时间测试。

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 214,128评论 6 493
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 91,316评论 3 388
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 159,737评论 0 349
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 57,283评论 1 287
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 66,384评论 6 386
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 50,458评论 1 292
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 39,467评论 3 412
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,251评论 0 269
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 44,688评论 1 306
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,980评论 2 328
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,155评论 1 342
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 34,818评论 4 337
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 40,492评论 3 322
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,142评论 0 21
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,382评论 1 267
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,020评论 2 365
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,044评论 2 352

推荐阅读更多精彩内容