本题的基本要求非常简单:给定个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
AC代码:
#include <cstdio>
#include <iostream>
#include <string>
using namespace std;
bool check_legal(string s) {
int pnum = 0, ppos;
for (int i = 0; i < s.size(); ++i) {
if ((s[i] < '0' || s[i] > '9') && (s[i] != '.' && s[i] != '-'))
return false;
if (s[i] == '-' && i != 0) return false;
if (s[i] == '.') {
pnum++;
if (pnum > 1) return false;
ppos = i;
}
}
if (pnum > 0 && ppos < s.size() - 3) return false;
if (stod(s) > 1000.0 || stod(s) < -1000.0)
return false;
else
return true;
}
int main() {
int n, cnt = 0;
double sum = 0.0;
string s;
scanf("%d", &n);
for (int i = 0; i < n; ++i) {
cin >> s;
if (!check_legal(s))
cout << "ERROR: " << s << " is not a legal number" << endl;
else {
cnt++;
sum += stod(s);
}
}
if (cnt == 0)
printf("The average of 0 numbers is Undefined");
else if (cnt == 1)
printf("The average of %d number is %.2lf", cnt, sum);
else
printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
return 0;
}
总结:
1、stod()可将string转化为double
2、题目核心是要判断输入是否合法。当前字符不是数字不是小数点也不是符号时,直接非法;负号出现在非首位非法;小数点数目大于1非法;小数位数大于2非法;转化后的浮点数不在区间[-1000,1000]内非法。除此之外,合法。