题目描述
The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
A binary search tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.
Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A.
if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y.
where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found.
or ERROR: V is not found.
or ERROR: U and V are not found.
.
Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
考点
1.二叉搜索树、先序遍历、最小公共父结点。
思路
递归实现
判断根结点与两个结点的相对位置关系,如果两个结点都在根结点的左边,那么它们的最小公共父结点一定在根节点的左子树上;在右边的情况类似。如果分别位居左右,那么这个根节点就是两个结点的最小父结点。
代码
递归实现
#include <iostream>
#include <vector>
#include <map>
using namespace std;
vector<int> pre;
map<int, int>pos;
void LCA(int a, int b, int r) {
if (a < pre[r] && b < pre[r]) {
LCA(a, b, r + 1);
}
else if ((a < pre[r] && b > pre[r]) || (a > pre[r] && b < pre[r])) {
cout << "LCA of " << a << " and " << b << " is " << pre[r] << "." <<endl;
}
else if (a > pre[r] && b > pre[r]) {
LCA(a, b, r + 1);
}
else if (a == pre[r]) {
cout << a << " is an ancestor of " << b << "." << endl;
}
else if (b == pre[r]) {
cout << b << " is an ancestor of " << a << "." << endl;
}
}
int main() {
int m, n;
cin >> m;
cin >> n;
pre.resize(n + 1);
for (int i = 1; i <= n; i++) {
cin >> pre[i];
pos[pre[i]] = i;
}
for (int i = 0; i < m; i++) {
int a, b;
cin >> a;
cin >> b;
if (pos[a] == 0 && pos[b] == 0) {
cout << "ERROR: " << a << " and " << b << " are not found." << endl;
}
else if (pos[a] == 0 || pos[b] == 0) {
cout << "ERROR: " << (pos[a] == 0 ? a : b) << " is not found." << endl;
}
else {
LCA(a, b, 1);
}
}
return 0;
}
贴一个柳神的代码,循环实现
#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
int m, n, u, v, a;
scanf("%d %d", &m, &n);
vector<int> pre(n);
for (int i = 0; i < n; i++) {
scanf("%d", &pre[i]);
mp[pre[i]] = true;
}
for (int i = 0; i < m; i++) {
scanf("%d %d", &u, &v);
for(int j = 0; j < n; j++) {
a = pre[j];
if ((a >= u && a <= v) || (a >= v && a <= u)) break;
}
if (mp[u] == false && mp[v] == false)
printf("ERROR: %d and %d are not found.\n", u, v);
else if (mp[u] == false || mp[v] == false)
printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
else if (a == u || a == v)
printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
else
printf("LCA of %d and %d is %d.\n", u, v, a);
}
return 0;
}
果然柳神的代码看起来简单多了!