sicily_1024 Magic Island

题目

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

There are N cities and N-1 roads in Magic-Island. You can go from one city to any other. One road only connects two cities. One day, The king of magic-island want to visit the island from the capital. No road is visited twice. Do you know the longest distance the king can go.

Input

There are several test cases in the input
A test case starts with two numbers N and K. (1<=N<=10000, 1<=K<=N). The cities is denoted from 1 to N. K is the capital.

The next N-1 lines each contain three numbers X, Y, D, meaning that there is a road between city-X and city-Y and the distance of the road is D. D is a positive integer which is not bigger than 1000.
Input will be ended by the end of file.

Output

One number per line for each test case, the longest distance the king can go.

Sample Input

3 1
1 2 10
1 3 20

Sample Output

20

题目大意

N个城市、(N-1)条路的岛,K为首都。从K出发,每条路只走一遍,问走过的最大距离。

思路

用变量maxDistance存所求最大距离。DFS搜索每个路径,当当前路径大于maxDistance时,当即更新。

代码

// Copyright (c) 2015 HuangJunjie@SYSU(SNO:13331087).
// sicily 1024: http://soj.sysu.edu.cn/1024
#include <cstdio>
#include <vector>

#define MAX_SIZE 10000

using namespace std;

struct Road {
  int id_;      // road id.
  int end_;     // the other end of the road
  int length_;  // the length of the road

  Road(int id, int end, int length) {
    id_ = id;
    end_ = end;
    length_ = length;
  }
};

int maxDistance;
vector<Road> Roads[MAX_SIZE + 1];   // Roads[0] is useless
bool visited[MAX_SIZE + 1];         // visited[0] is also useless


// DFS searching the roads. for the implementation is recursive, the closed list
// have to be global.
// @Param start: a city that begin the visit.
// @Param pathLength: gets a certain path's length. if the path is longer than
// the max distance we knows, update the maxDistance.
void DFS(int start, int pathLength = 0) {
  // for each road connected to start
  for (int i = 0; i < Roads[start].size(); i++) {
    // if the road is not visited
    if (!visited[Roads[start][i].id_]) {
      // visits it
      visited[Roads[start][i].id_] = true;

      // adds the road length to the path length
      pathLength += Roads[start][i].length_;
      // update the max distance
      if (pathLength > maxDistance) maxDistance = pathLength;

      // continue the path from the other end of the road
      DFS(Roads[start][i].end_, pathLength);

      // [IMPORTANT] back tracking
      pathLength -= Roads[start][i].length_;
      visited[Roads[start][i].id_] = false;
    }
  }
}

int main() {
  // the cities' number N and the capital's number K
  int N, K;

  while (scanf("%d %d", &N, &K) != EOF) {
    // initialization.
    maxDistance = 0;
    
    for (int i = 0; i <= MAX_SIZE; i++) {
      Roads[i].clear();
      visited[i] = false;
    }

    // gets the total N-1 roads.
    int start, end, length;
    for (int i = 1; i < N; i++) {
      scanf("%d %d %d", &start, &end, &length);
      // bidirenctional roads
      Roads[start].push_back(Road(i, end, length));
      Roads[end].push_back(Road(i, start, length));
    }

    // DFS the roads from the capital.
    DFS(K);

    // output the max distance visited.
    printf("%d\n", maxDistance);
  }

  return 0;
}

参考

http://www.cnblogs.com/joyeecheung/p/3505124.html

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,402评论 6 499
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,377评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,483评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,165评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,176评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,146评论 1 297
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,032评论 3 417
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,896评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,311评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,536评论 2 332
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,696评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,413评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,008评论 3 325
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,659评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,815评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,698评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,592评论 2 353

推荐阅读更多精彩内容

  • 【情景】何谓形式分析?我们看到一件艺术品,一张生活照,一间起居室,直觉会告诉我们,喜欢或是不喜欢,肯定或是否定。形...
    旅衣阅读 1,381评论 0 0
  • 上高中的时候,我得了偏头痛,到了后期不得不喝营养品才能够得到缓解,偏头痛让我经常失眠。睡觉对我来说是个痛苦的事情,...
    张德祥阅读 917评论 0 4
  • 在这没有孤单 在这我们一起奔跑 在这我们一起成长 这是我们一同奔跑前进的团体,在这我们每天都会发一篇日记,这将是我...
    穿山阅读 239评论 4 0