给定任一个各位数字不完全相同的 4 位正整数,如果我们先把 4 个数字按非递增排序,再按非递减排序,然后用第 1 个数字减第 2 个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的 6174,这个神奇的数字也叫 Kaprekar 常数。
例如,我们从6767开始,将得到
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...
现给定任意 4 位正整数,请编写程序演示到达黑洞的过程。
输入格式:
输入给出一个 (0,) 区间内的正整数 N。
输出格式:
如果 N 的 4 位数字全相等,则在一行内输出 N - N = 0000;否则将计算的每一步在一行内输出,直到 6174 作为差出现,输出格式见样例。注意每个数字按 4 位数格式输出。
输入样例 1:
6767
输出样例 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
输入样例 2:
2222
输出样例 2:
2222 - 2222 = 0000
代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int convert_to_int(int array[]){//数组返回为整型
int final=0,ten=1;
for(int i=3;i>=0;i--){
final=final+array[i]*ten;
ten*=10;
}
return final;
}
void convert_to_array(int num,int array[]){//整型存储进入数组
for(int i=3;i>=0;i--){
array[i]=num%10;
num/=10;
}
}
bool down(int a,int b){//降序
return a>=b;
}
int main(){
int N,L,R,temp[4]={0};;
scanf("%d",&N);
while(1){
//这里不能写成 N!=6174 ,否则测试点5无法通过
//因为如果你输入6174那程序就不会有任何输出了
convert_to_array(N,temp);
sort(temp,temp+4,down);
L=convert_to_int(temp);
sort(temp,temp+4);
R=convert_to_int(temp);
N=L-R;
if(temp[0]==temp[1]&&temp[1]==temp[2]&&temp[2]==temp[3]){
//测试点1:如果每个位的数字都相等,输出一次就结束循环
printf("%04d - %04d = %04d\n",L,R,N);
break;
}
else{
printf("%04d - %04d = %04d\n",L,R,N);
}
if(N==6174)//
//当结果是6174的时候就终止循环
break;
}
return 0;
}