Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
理解
给你一系列的数,找出一段数,使得这段数的和最大,输出最大和和这段数的始末。
代码部分
#include <cstdio>
using namespace std;
int t,n,l,r,a,w;
long long sum,max;
int main(){
scanf("%d",&t);getchar();
for(int i=1;i<=t;i++){
scanf("%d",&n);getchar();
l=1;r=0;w=1;
sum=0;max=-100000000;
for(int j=1;j<=n;j++){
scanf("%d",&a);
sum+=a;
if(sum>max){
max=sum;
r=j;
l=w;
}
if(sum<0){
sum=0;
if(a<0)
w=j+1;
else
w=j;
}
}getchar();
printf("Case %d:\n%lld %d %d\n",i,max,l,r);
if(i!=t) printf("\n");
}
return 0;
}