3-3 后续遍历树

03-树3 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

二叉树

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目分析

给了中序的非递归遍历方法,求后序遍历的二叉树输出

我的答案

//
// Created by allenhsu on 2018/10/31.
//

#include <iostream>
#include <vector>
#include <stack>
#include <string>

using namespace std;
// 传入后序序列的引用 核心代码!
void getPostOrder(vector<int> preOrder, int preL, vector<int> inOrder, int inL, vector<int> &postOrder, int postL, int n){
    if (n == 0) return;
    if (n == 1){
        postOrder[postL] = preOrder[preL];
        return;
    }
    auto root = preOrder[preL];
    postOrder[postL + n - 1] = root;
    int i;  // 中序遍历的root位置
    for (i = 0; i < n; ++i) {
        if (inOrder[inL + i] == root) break;
    }
    int L = i, R = n - i - 1;
    getPostOrder(preOrder, preL + 1, inOrder, inL, postOrder, postL, L);
    getPostOrder(preOrder, preL + L + 1, inOrder, inL+L+1, postOrder, postL+L, R);
}

/**
 * 根据输入返回前序和中序遍历vertor
 * @param N 该二叉树的节点个数
 * @return 返回两个vertor序列
 */
vector<vector<int>> getOrder(int N){
    vector<int> preOrder(N, 0);
    vector<int> inOrder(N, 0);
    stack<int> s;
    int preL = 0, inL = 0;
    for (int i = 0; i < 2 * N; ++i) {
        string str;
        int tmp;
        cin >> str;
        if (str == "Push"){     // str可以直接比较
            cin >> tmp;
            s.push(tmp);
            preOrder[preL++] = tmp;
        } else if (str == "Pop"){
            inOrder[inL++] = s.top();   // top 返回栈顶元素
            s.pop();
        }
    }
    return {preOrder, inOrder};     // 返回数组vector
}

int main(){
    int N;
    cin >> N;
    auto order = getOrder(N);
    vector<int> postOrder(N,0); // 初始化动态数组要指明参数
    getPostOrder(order[0], 0, order[1], 0, postOrder, 0, N);

    int i = 0;
    for (; i < N - 1; ++i) {
        cout << postOrder[i] << " ";
    }
    cout << postOrder[i] << endl;
    return 0;
}

感悟

本次的作业自认为挺难的。我没有独立完成,是copy网上自己读懂后敲得。值得再回头多看几遍。核心函数getPostOrder(); 理解其中的递归求解思路。

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 216,591评论 6 501
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 92,448评论 3 392
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 162,823评论 0 353
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 58,204评论 1 292
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 67,228评论 6 388
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 51,190评论 1 299
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 40,078评论 3 418
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 38,923评论 0 274
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 45,334评论 1 310
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 37,550评论 2 333
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 39,727评论 1 348
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 35,428评论 5 343
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 41,022评论 3 326
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 31,672评论 0 22
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 32,826评论 1 269
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 47,734评论 2 368
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 44,619评论 2 354

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,322评论 0 10
  • 我跟我婆婆其实没仇,甚至都谈不上正面冲突,但是我几乎没法直视她,或者和她说话。有时候我想想单纯是因为我嫁给了他儿子...
    Phyllisjia阅读 466评论 3 1
  • 买的画纸到了,人力抱回来~ 怕你们想念我,上图以解相思之苦~ 最近都不算太乖 想要干点大事,哈哈哈 电脑买了快一年...
    断三石阅读 206评论 0 0
  • 在空无一人的操场 在下午的五点多 在依然温和的阳光中 张开双臂 像一位芭蕾舞者 踏着呼吸的节奏 大概背影看起来 不...
    禾茉阅读 99评论 0 0
  • 这是一个关于修蓝博士在不见面的情况下治愈精神病患者引发的故事,所用的就是荷欧波诺波诺疗法。 这听上去有些令人不可思...
    总有奇遇_琦琦阅读 1,070评论 0 0